aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkatherine <ageha@airen-no-jikken.icu>2024-03-06 03:08:54 -0700
committerkatherine <ageha@airen-no-jikken.icu>2024-03-06 03:08:54 -0700
commit0c290cf90b825252a91c15decd36fc6dd8f0b95b (patch)
tree39947c2338733c191488d0f36aa39f71b51f904b /PKGBUILD
parent8d527788821faee1a2f961d576997351cd68767d (diff)
downloadbk-0c290cf90b825252a91c15decd36fc6dd8f0b95b.tar.gz
dumb forkHEADmaster
use for now until bk has config and such
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..99f598e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=bk
+pkgver=0.6.0_fork
+pkgrel=1
+pkgdesk="terminal epub reader (fork)"
+arch=('i686' 'x86_64')
+url="https://github.com/aeosynth/bk"
+license=('MIT')
+makedepends=('rust')
+source=()
+
+build() {
+ cd ..
+ cargo build
+}
+
+package() {
+ cd ..
+ install -D -t "$pkgdir/usr/bin" target/debug/bk
+ strip -x --strip-unneeded "$pkgdir/usr/bin/bk"
+}